Exchange with Goliath CNC users in France

Hello to all,
I am currently working on a professional furniture creation project. Looking for a CNC milling machine, I discovered the Goliath model on the Internet. I am very interested but I would like to see this machine in operation and discuss with their user. I am in France and I am looking to the community to contact goliath users in France. Thank you very much in advance for your feedback. Regards
Alain

Hi Alan, I am in Birmingham Uk, I have been trying to use the machine for the last couple of months. It is fantastic when it works but few bugs being sorted by springa. Most of the info is available on their website. Not many users are posting their projects I am one of them.
I have placed it in my sons bedroom on the floor, after he moved out his bed- You can carve/cut big projects.
I am looking forward for a uk group. :grinning_face_with_smiling_eyes:

2 Likes

I’m in France. Deux Sévres. Where are you?

Hello i"m in france, Verdun :slight_smile:

Bonjour,

Je suis basé à côté de Nevers (58). Est-ce possible de se contacter pour échanger sur la CNC Goliath??
J’aimerais avoir votre avis sur l’utilisation de cette machine. Merci beaucoup
Cordialement. Alain

Bonjour,

Je suis basé à côté de Nevers (58). Est-ce possible de se contacter pour échanger sur la CNC Goliath??
J’aimerais avoir votre avis sur l’utilisation de cette machine. Merci beaucoup
Cordialement. Alain

Bonsoir Alain,
Bien sûr sans problème le plus simple via Facebook je pense?

Unfortunately, I haven’t been able to get Goliath to work. Slingshot can’t see it.

So far, I’ve been impressed with the design and the build quality but I’m disappointed I can’t get it to work and the lack of reply from support.

I hope I haven’t got a faulty machine.

Hello there, sorry for the late reply, company was closed for holidays.
As per our email exchange, I kindly ask you to keep us updated, probably the problem you are experiencing is related to a direct connection problem with Goliath, so we ask you to try to connect to your wi-fi network instead and let us know if works.

I’ve had a breakthrough. I bought a TP Link wifi dongle for 9 euros. I’ve no idea why but now Windows 10 in VMWare (seems much better than Virtualbox) realises that it has wifi.

I managed to get to the end of setting up Slingshot with Goliath and it told me to wait until the connection was made. Nothing happened, so I did it again. And again. And again. What I didn’t realise is that Slingshot had connected, it just didn’t tell me. So I then went into Slingshot and set it up using the button on the left. So far, so good.

Today I’ll try and cut with Goliath.

My current struggle is updating the firmware. I’ll see if my 11 year old can work it out.

1 Like

I’m glad you were able to connect. As for the firmware, what problems are you experiencing specifically?

Getting the Goliath Firmware tool to work was the problem. As far as I’m aware, there was no mention of the two other pieces of software you need to make it work.

Fortunately another member of the forum gave a very good instructions along with screenshots. It was only because of that that I managed to get it to work.

I’ve had a whole series of other problems. I’ve just sent a long detailed email to support about today’s disasters.

1 Like

Hello, thanks of your answer, we’ve just sent you an e-mail so we can give you support

We all had our fair share of problems. But when it starts to work it is brilliant and no dust.

Have you managed to get it to work properly?

Mine is working fine now but with goliath wifi and I can send messages on my phone as the pc internet is taken over by goliath wifi with limited internet.

1 Like

What problems did you have?

Mainly wifi problems, if connected to goliath wifi no internet access (this preventing authorisation from internet (in my openion) ) I had to repeat the sequence of panel detection few times and it will start working.
Spindle cage open erros many times, spinfle under the cable etc.
I use windows 8 pc I 7 processor but still some times takes ages to load the slingshot specilly if I have few projects on the dashboard. - I have now only 2 or 3 projects and othes I have saved as zip files.
Firmware uploading a problem I realised after few attempts it is desktop version of .net not the laptop version.
It is fun and some times frustrating to sit for hours before cut.
Having said it is better now and am still experimenting.
Uploaded few pictures in gallery. Using mdf for now.
Very impressed that there is hardly any dust.

1 Like

I had wifi problems to start with but mainly because I did’t know what I was doing. Fortunately someone on this forum explained the .net problem clearly. If it hadn’t been for that, I never would have solved it.

I also get spindle under the cable and it’s also a problem the you want to access the top button but it’s under a spinner.

The main problems I have now are: not leaving tabs, accuracy, dust extraction and, most annoying, ‘obstruction’.

I’m cutting plywood and the dust extraction is superb but fibres build up and cause a blockage. I can tell when it’s about to happen and I stop Goliath to clear it but there doesn’t seem to be a way to raise the Z axis to be able to remove the spindle cover, I have to tip the machine over.

The obstruction problems by far the most annoying. There has never been an obstruction. Goliath seems inconsistent, sometimes I can restart the cut sometimes I can’t.

The funniest problem was when I tried to use the jog function. After one press the Goliath started dancing around the plywood. I wish I could post the video, it’s hilarious.

I can’t fault the support team, they have answered every email and now want to collect Goliath to have a look. If only all manufacturers were like that.

1 Like

I don’t use jog function in automatic mode but use in manual mode when goliath is free to move and then i could check the placement of my art work on the canvas.
A couple of times it got confused and gave me error message


Even before the gcode calculation. Had to restart and redo every thing few times then it was fine.
I had once message to empty the dust bin.
There is a plan to lift zaxis by pressing the top button in future it seems.
Still there are many unanswered questions.
But I am happy as it does the job and keeps me engaged.

1 Like