Goliath doesn't react to any command

Hi, I’ve just received the Goliath and tried to use it.

Slingshot tells me that Goliath and towers are connected, but unfortunately, I have the impression that Goliath doesn’t react to any commands at all. Here are two examples:

  1. in the Jog Mode set on “manual” Goliath doesn’t ‘unblock’ the wheels allowing me to move it.

  2. when I send the G-Code to Goliath, the machine doesn’t lift the Z-axis, start moving/cutting, or do anything at all…

I’ve watched all the tutorials many times and followed the instructions step by step but nothing changed. What can I do?

Should I try to update the Firmware? I did not find any Instructions/tutorials on your website on how to do it…

1 Like

Hi Stefano, please find below the link to our guide on how to update the firmware

Let us know if the problem persists

@Stefano keep us posted. Any info on the fix should be good for the community. I thought the Goliath went past beta testing already?

Sometimes you need to repeat the process a few times. I had problem with jog mode and resadjusted the cut on the canvas and ready for calculate path then it says this…


Repeated twice then it worked.- jog bug.

Hello, could you please send us at info@springa.tech your log file and project, so we can make some test?

Hi Lucia,
I am happy to send the log file, but it is working now and the log might have been changed and you may be solving so many other problems and I do not want to inundate your team with loads of logs to go through.
My solution is to redo the process and goliath will find a way to solve.
The jog mode does work well but I only use in manual mode as my work area has lot of obsticles and I want goliath to stay only near the cutting art work- hence I move the art work after exiting the jog mode, probably it is too much and send an error code. But it worked after a couple of times. ( I lost the art work changes and had to repeat them each time.)
Learning point is to save by using save icon on the top before going on jog mode.

2 Likes

You are a real asset to the community!

1 Like

I had this same issue when using my wifi (even though it joined fine). I changed to the Goliath native adhoc wifi and it then showed as moving on the screen.

I then had continual issues getting the towers to sync with Goliath when using my wifi so I am simply using adhoc to Goliath for now. I use Ubiquiti AP AC Pro and AC HD access points.

I suspect the older IP stack and security features of the Goliath wifi software are partly to blame for communication issues although I haven’t tried to capture any of the traffic.

-William