Goliath Won't Cut

I received Goliath last week and I tried to setup a file for it to cut this weekend, but ran into a number of issues that I’m trying to understand. I did the panel detection process using the sensor method. Once completed both towers and Goliath sensors were green and the workspace was set correctly. I positioned the pieces to be cut in the location on the workspace where I wanted them cut out from and I sent the file to calculate the GCode for Goliath. Everything appeared to calc correctly and sent to Goliath. I did notice that there are these errors that show under the Gcode button but nothing before the code was sent.


The Golaith unit then requested a bit change and did a Z-Axis calibration. After that I hit the play button and the Goliath unit proceeded to move around just a tiny area and not actually cut anything.
It did this for aprox 30 min before I decided to stop it. I was then stuck in the cutting part of the program with no options to back out or change anything. I then tried to close slingshot and reopen it to reconnect. I was unable to do so and was shown the message to let Goliath finish the job. I then hit the play button again and Goliath continued to do its very small movement with no cutting. I let that go for about another 20min and finally shut the machine down. I then went through all of the steps of panel detection, workspace creation, file placement , GCode creation and a Z-Axis calibration and this time Goliath wouldn’t cut anything it just sat there. Goliath Position Incorrect
I’ve watched all of the tutorial videos a few times and I don’t understand what I’m doing incorrectly. Here’s a pic of the pieces I was trying to have Goliath cut out. Parts I was trying to cut and finished with Shaper Origin
I have tried to attach both a video of the Goliath doing the small movements with no cutting and the actual project ZIP but I can’t in this forum any help with this would be greatly appreciated.

Thanks,
Brennan

Hi,
i think that there is no path configured.
in 2. picture i can see only the tool change instruction.
try at first to define your path(es) with cutting data in the canvas at beginning.
is the svg good imported AND on the canvas?
if there is no stop or danger symbol at the display on the upper left it should work.
hope i could give u a hint.

chab

The #2 picture was from the 2nd trial when slingshot wouldn’t even recognize where Goliath was in the work area. In reality the Goliath machine was sitting in the middle of the workspace but the software shows just a graphic of it in the corner. The svgs should be good, I opened them in inkscape and went through all of the conversion process as defined in springa’s tutorials before importing into slingshot. All of the tracks/cutting data (i.e. depth, interior cut/exterior cut etc., bit) were defined. I can’t see a way to define a cut path in slingshot (am I missing something? Isn’t that what is happening on the backend when you say send GCode?).

2 Likes

Hey Brennan, I saw the Shaper Origin, I am really anxious to see your resulting cuts with the Goliath if it will be up to par with the Shaper. Please let us know! and maybe comparison photos!

I’d like to provide that information and photos, but right now I can’t get my Goliath machine to make any cuts. :slightly_frowning_face: I can’t really trouble shoot the errors from slingshot any further. It just translates to “errors in the data” but there weren’t any errors showing before I calculated the GCode. Maybe slingshot doesn’t like my SVG??? It’s hard to know what the issue is.

I believe the SO’s intuitiveness/ease of use and website/design hub are far better, but I also think the user base and company to be more established than Springa/Goliath so that’s not very surprising. In theory the cuts that come from the Goliath should be better as the machine won’t get tired of moving unlike my arms with the SO. :wink:

1 Like

Hello there, we’ve just sent you an e-mail so we can give you support :slight_smile:

I’ve had no end of problems. I admire what Spring is trying to do but, so far, it just doesn’t work.

Interesting. The art work you plan to cut is small and the bit feed rates are too fast in my openion. The size of the highlited part is 12cm by 1.5cm and a 3.18mm bit may find it challenging.
Would like to see it resolved.

I got closer than ever to finishing a job today. Unfortunately, I didn’t.

Here’s what I had in slingshot:


![Screenshot 2021-12-14 at 16.47.22|690x426]

This is what I got:

All four tabs were left off and it was 196.9 x 195.6 instead of 197.11 square. A long way from the 0.1mm tolerance Goliath is supposed to have.

Hopefully Spring will be able to sort it out soon.

1 Like

Goldfinger, I can understand that feeling. With any brand new tech/hardware there are always going to be issues to work through and resolve especially with a growing user base testing all sorts of new things. This is part of the Maker process, hopefully in the end everyone ends up happy. :grinning:

2 Likes

I certainly hope so.

When you change the bit to spiral one what parameters did you use?
I am just using a 60 degree v bit to create some detail. I realised that the new bit plunge depth defaults to 0 mm then I changed to 0.2mm and it is cutting now.

I should have used 0.2mm instead of 0.6mm cut depth.


After I created the 1/8" spiral up-cut bit I did have to set the depth for all of the cuts when I initially put in the svg/tracks. You can see that in the project screen grab from further up this thread that I had them all set at my desired depth of cut. You may be right that the feed rate might have been a bit high but I think the bigger problem was the Goliath wasn’t moving correctly most likely due to some issue with the SVG and GCode creation.

Recheck plunge depth on the custom settings of your spiral bit. It should be more than 0
I put it as 0.2mm on my v carve bit. Try on a small test on mdf first.

I’m not really sure what you are referencing. I don’t see a plunge depth on my Custom bit when I created it or open it. I can only set plunge depth on the track in the project. Here’s a pic of my bit setting.

When you sellect the bit on the track window you change the bit to 1/8 spiral and you sellect custom sellection and change the feed rate and plunge rate and plunge depth the last row on the right side of the screen. Sorry don’t have a picture to share.

This was what I had posted earlier up this thread, but I’ve updated the feed rate and plunge on the bit from the original 1000 & 300 to 400 & 200. I can’t actually adjust the custom settings in the slingshot project directly it all gets pulled automatically from the bit settings in the machine dashboard. My version of slingshot is 1.7.12.0
I don’t think this is really the problem. The Golaith movement wasn’t really happening correctly. If I could post a video of the movement it might make more sense, but I can’t on this forum. I’m waiting on the Springa team to give more insight as I’ve sent them a bunch of requested files and logs.

Hi Bmreddin,
let me introduce myself, I’m Davide Cevoli, one of the cofounders of Springa.

Firstly I want to thank you and everyone else here for sharing your feedback with us.
This really helps us to improve our product and software.

I’ve read your posts and I’ve checked the files you have sent to Lucia.

Thanks to your project we have identified two bugs of Slingshot and we are working on them.

The first bug consists that Slingshot lets you get in the cutting phase even if the path’s (GCode) calculation fails, as your first screenshot shows.

We are improving Slingshot so that it will not happen again. It will tell when the path’s calculation fails and you will not able to get into the cutting phase until the cause of the failure is removed.

The second bug is what causes the path’s calculation to fail. We found out that the problem is in the name you gave to the bit. Not the whole name but only the Ditto Mark you used as inch symbol ( " ). In the next version, Slingshot will accept the Ditto Mark in the bit’s name. At the moment this can be solved just by deleting the Ditto Mark from the name or by replacing it with two single Apostrophes ( ’ ).

Thank you again for your feedback.

2 Likes

Hi Bmreddin
Please let the forum know if the naming correction made the required change.
I have nmed my custom bit as vbit and it worked.
Good luck.

The Goliath made some cuts from the project. I had to complete the panel detection process 6 times. Then the machine started to make its 1st cut and got stuck in a small movement pattern with no z-axis movement. I watched it for aprox. 5 min and then hit the play/pause button on the machine (yellow button) to pause it and then play and the picked up and moved onto the next track. The machine proceeded through 10 of the 73 sequences just fine before it lost connection to tower 2??? Both towers are plugged in and right by my WIFI connection. I then tried the play/pause button again but nothing happened the machine just kept running with the bit spinning down in the MDF! I then tried what the slingshot error says to do which is restart the machine and software and now I’m back at the panel detection with no way to get back into the cutting operations part. :slightly_frowning_face:



Here’s what the machine did cut (from an accuracy standpoint it’s not looking good)

1 Like