Open and closed paths

I’m running into some frustrating issues with the slingshot software. I keep getting the frustrating issue that the software does not detect certain shapes as being closed.

image

The strange thing is that these shapes are certainly closed! I double checked this with both illustrator and inkscape, with every possible standard of the svg file. In fact the shapes you see are literally copies of each other (made in inkscape), but slingshot refuses to recognize these as closed shapes.

Does anybody have some good input on this? I had some good results yesterday with illustrator simplify shape, but I cannot get the same results reproduced…

Alright, got a short update! No idea what causes it, but its possible to resolve this by using a rectangle + union in inkscape.

Some images:
slingshot indicated an open path here:
image

Set to fill color and linewidth of 0
image

make a new rectangle (here in gray) and have it snap to the corner. If it doesn’t snap correctly, check the snapping bar in inkscape to set the right snapping
image

Select both, and do Path > union

Then set the fill back to none and enable linewidth. This resolved the issue for me. Still quite cumbersome, and not so easy for many complex shapes, but it’s something! Hope this helps some people :slight_smile:

1 Like

Hallo ich muss sagen leider habe ich gleiche und mehr Probleme. Was ich etwas enttäuschend finde ist der Support den der Goliath ist nicht gerade günstig gewesen. Ich selber arbeite mit verschiedenen CNC Maschinen aber das was ich hir erlebe mit dieser Software ist Freude klauend (frustrierend) in all meinen programmen die ich besitze funktioniert es bei Slingshot einfach nicht ob mit der Tiefe oder geschlossener Kreis, Z Achse, Maschinen Stop und weiter fahren und und. Bin führ jeden guten Tipp Dankbar.
Freundliche Grüsse
Emmanuel Bettoli

As I wrote in my other post I found one reason for the closed path problem. I opened the svg file in a text editor and I saw that all the shapes that I had problems with started similar this: "<path d=“M23.9193068,-9.7982712 L23.9193068,-9.7982712” where the M-coordinates (starting point) and the L-coordinates (line) where the same. When I removed or altered the first line coordinates Slingshot understood them as closed. I don’t know if this is the only bug, but at least it worked for my files.

I also tried to convert letter to path in Inkscape but it seems like Slingshot doesn’t understand the “Q” type of bezier curves (quadratic curve) that Inkscape made. But when I draw bezier curves in Inkscape these were “C” type of Bezier curves (cubic curves) which Slingshot understand. It is possible to convert quadratic bezier curves to cubic bezier curves, but an easier solution was to write the letters in Fusion 360 and then use the Shaper utilities add on to convert it to svg. I had to make the drawing in Fusion 360 ten times bigger than it shoud be, because Shaper utilities uses cm in the svg while Slingshot understand it as mm. The Shaper utilities converts the letters to small straight line segments (Path element and L command in the SVG files), so that’s also a reason for making big letters in Fusion and reduce the size in Slingshot to get nice letters, instead of doing the opposite.

1 Like

Oooh! thanks! I need to try that trick out, thanks!

Alas! That was not the problem for me unfortunately. The weirdest thing is that sometimes the issue can appear when you copy paste a shape. So when working in inkscape all shapes are good after import to slingshot, then I try to copy a few of these (correctly accepted closed shapes by slingshot!) in inkscape, and then the issue is present in slingshot with the newly copied shapes. Strange!

If you post the svg file I can take a look and see if I can spot the problem.

1 Like

Hello, thank you for all your reply.
We inform you that we have fixed the open path bug and you will be able to notice the difference with the next SW release at the end of August.

2 Likes

thanks! I managed to resolve it myself, but still thanks for the offer :slight_smile: