Cannot connect to Goliath and Tower Sensors

When going through setup, cannot complete setup. Goliath and Towers have been updated to latest firmware (as of 5/7/22) and cannot connect Slingshot, Goliath and Towers together. Regardless of connection type chosen, the software does not connect to Goliath and then connect to Towers. The first time I tried to setup, by connecting to existing home WiFi network. Eventually got Goliath to be recognized and calibrated the yellow spinner sensor…but neither of the tower sensors connected. Pressed and held the yellow button on Goliath 5 seconds to reset connection and rebooted; now I cannot connect to Goliath at all on the connection page. Please advise.

Hi, the problem you are experiencing may be related to a connection bug in the latest software version of Slingshot. An update will be released this week which will resolve the issue. In the meantime we are contacting you privately to ask for some additional information.

1 Like

Lucia, I was able to download and install Slingshot 1.08.02 and get Goliath and the Towers to connect. I was also able to send GCode to Goliath. When it came time to change the bit and begin cutting, the Z-Axis would not lift to remove the spindle protection and allow me to insert the bit.
I aborted the production screen (since there were no controls to move the z-axis up) and then had to restart both Goliath and Slingshot. Now, I cannot connect to Goliath or the Towers…Again despite multiple restarts on both the hardware and software. I’m very frustrated with this since I have spent about 6hrs trying to get this to work and have yet to hear or see the spindle turn, let alone cut anything.

1 Like

Hello, thanks for your answer, we are contacting you privately. We need to ask you for some files and materials in order to better understand issue you are experiencing.

Hello, when having problem in connecting towers, we advice to:

  1. Verify the status of charge of the tower by checking the LED located near the sensor’s USB input (Maybe the sensor battery is low):

    ● Green: Battery charged
    ● Flashing red: battery with less than 20% charge
    ● Fixed Orange: USB cable connected while charging.

    Is possible to work while tower sensor are charging.

  2. Change connection channel of tower sensor to Goliath on slingshot (Maybe there is an interference).

Hello, I’m having more a less similar problem. I get connection with Goliath established, but I just can’t get through the sensor connection setup. I click ‘Connect’, the spinner shows and after few seconds disappears - nothing happens. Tried all possible configurations from the ‘Select sensors channel’ dropdown but nothing works.

It worked fine previously. I started having this problem yesterday. Restarted Goliath and sensor towers several times with no success.

Firmware is updated.
Batteries are fully charged.

Hi, thanks for your post, do you think there is any possibility of interference at the place where you are working? Could you send us your log file for the date you started having the problem to You can reach the folder where it is contained by pasting the following link C:\Springa\Slingshot\Log in the document path bar.

Thanks for response. I have Goliath connected in my apartment. There shouldn’t be any serious interferences since it’s just a normal household. Probably wifi could be the only source of problems.

I’ve sent you an email with the logs.

Hi thanks for your post, we just emailed you back, we suggest you try restarting the wi-fi by switching the machine off and on again and restarting Slingshot. You can also connect to an existing network rather than the Goliath-produced network.

Hello, I’ve tried to restart both Slingshot, Goliath and towers multiple times. Probably around 20 or 30 times. I managed to connect sensors only once when I chose ‘Configuration 0’ for ‘Select sensors channel’ dropdown (for some reason ‘Configuration 1’ is selected as default). I have tried the same configuration later on but it didn’t work again. I get constantly either ‘Unsuccesfull connection’ error, or no error at all. Just no possibility to go to the next step.

I tried to connect Goliath to an existing network but no network is being displayed. I tried to restart Goliath as it’s stated in the comment on the top of that view, refreshed the list, but no network is being displayed. It worked only once. I got a list of available networks, I tried to connect to my local wifi network but it was never succesfully established. Just waited for 10 minutes and nothing happened. I restarted all devices and Slingshot but this time I couldn’t get any network displayed.

I’m getting really upset. It just works randomly and very rare. I had to cut something right now and I can’t make it work.

I installed software and firmware updates just to be sure it’s not a problem but everything is up to date and still it doesn’t work.

I tried to upload images but there is a limit for new users max 1 per post.

I tried to upload more images as single responses but reached a limit of 3 responses… So I can’t upload all the screenshots I made.

Have you tried restarting your PC? This fixed the problem for me.

I had similar issue in the past- it appear your software and firmware is up to date. I undetstand goliath tries to connect either its network(local) or existing network. If you are using a pc you can check in network connections.( preferred connection is existing network, with local network the internet will not be available hence goliath can not connect to server)
So restart your computer, check for your internet if multiple networks available use the most stable one and forget othets- now start goliath and press the yellow button for a period till it become red( resets the wifi connections), then turn goliath off and on again as you are doing panel detection- it may first connect to local network( check the lights on top of goliath ) if goliath is connected through local network then change to existing network(through router). It will take a while to check for networks -when displayed sellect the correct one you have to reboot goliath before the network is established. You can now turn the tower sensors on and connect them if not connected reset the tower sensors by prssing the on button for awhile till led turns red and tower is off - then restart the towers again you should be connecting to tge towers now ig does not matter what configuration number- I guess this is if you have more than one goliath.
Good luck.
Once the chanel is established then onwards it will be straight forward.

Hi, by interference we also mean the presence of many available connections in the Wi-Fi list. Wouldn’t you perhaps have a chance to try using a different PC?

I have tried today to connect on a different PC and it worked there.

Still I can’t connect on the first PC. I will try @Bhimarasetty solution.

1 Like

Thank you for the feedback, keep us updated.

I also had some issues with connecting to Goliath… the tips and tricks that worked for me:

  1. Install the latest firmware.
  2. I use the Wi-Fi point of Goliath itself (direct connection) but I switch on Goliath first so it’s Wi-Fi signal is “up and running”.
    On my laptop/PC I switch off and on my Wi-Fi interface… only then my PC can make the connection with Goliath (Windows 10 is not Wi-Fi friendly on older PC’s and laptops, I have a Realtek RTL8723BE chip).
  3. Now switch on your towers. I use “Configuration 1” for my towers.
1 Like

Thank you for sharing :slight_smile: