Goliath won't move

Hi there,

This is SO frustrating. This device took more than two years to arrive beyond the promised delivery date and yet it STILL doesn’t work consistently (based on my own experience AND the numerous bug related posts). C’mon Spring…please do better! Now onto the problem…

What I am able to do:

  1. I’m able to make a direct connection to Goliath’s wifi.
  2. I’m able to successfully detect the panel and make it through the set-up (including connecting to the towers).

What I can’t do:

  1. Get the spindle to move at all when trying to raise the z-axis. Hence I can’t even get the dust protector on.

  2. Get Goliath to ‘jog’. If I move Goliath manually, I can see it move ‘virtually’ on the work area. But entering any x/y values or using the directional arrows does nothing.

  3. If I send the gcode to Goliath for a simple cut, I run into a bit change request which effectively puts me in limbo as I can’t get out of this page to get to the ‘play’ button. I’ve also tried pushing the yellow button on top of Goliath (to calibrate Z?) to no effect. I’ve also tried adding my own bit with a compliant name and parameters identical to the 6.35mm bit (I’m in the US) and yet I still encounter the same issue.

I would REALLY like to get Goliath up and running. Springa please assist! Thank you.

1 Like

Did you install the latest firmware versions? Out of the box, Goliath doesn’t come with the latest versions of the firmware…

First, make sure you have the FTDI Chip USB-drivers installed: Drivers - FTDI
(Restart your computer after installation of these drivers).


Thank you for your suggestion. Yeah, I tried a firmware update but ran into a snag: 1) I can’t use the wifi update b/c I need a more recent version of the firmware to do so. 2) I tried the USB option but none of the com ports show up in the list even after downloading and installing the FTI drivers. I have a new pc running Windows 11. I’m not sure what I’m missing.

as I said from the beginning: providing a cable options would prevent problems.
Too late of course.
Kickstarter project owners should listen a lot more to their backers.

Did you restart your computer after installing the FTDI-drivers?

I’m running Windows 10 and had no problems with the firmware upgrade (also had to install some .NET 3.5 stuff).


Hi Koenraad,

Funny, I did install the VCP drivers but for some reason they didn’t install correctly. I ended up using the hardware troubleshooter, restarted my laptop and BINGO…the com port is now visible! As a result, I’ve been able to update the firmware on Goliath and it looks like all is functioning correctly based on my first test cut. Let the creativity begin!

Thanks so much.



Hi Jason, we are glad that you were able to solve the problem. We apologize for the delay in providing you with feedback, but the company was closed for the summer holidays. We remain at your disposal.