Slingshot .svg import with unexpected open vectors

Continuing the discussion from Slingshot editor:

Thanks for the reply
Now I would like to draw your attention to the next issue I do not understand.
I have drawn the lapstrakes and sections of a small boat in Rhino v7
Just curves in two dimentions and seen from the top view.
I will describe the steps I have taken and upload the corresponding numbered pictures.
Also I have the Rhino, Aspire and .svg files available

A: Drawing made in Rhino and export to file Export from Rhino to Aspire.svg
In Rhino I have done everything I could find to make sure the curves are closed
Picture: 1 initial drawing in Rhino.jpg

B: Imported the file in Aspire and checked if there were open vectors
Picture: 2 Aspire check for open vectors.jpg

C: Grouped the components in Aspire and nested them onto a sheet of stock of 1220_2750_8 mm made the toolpaths and simulated the result
Picture: 3 Operations simulation in Vectric Aspire.jpg

D: Exported the result via the file Sheet 1.svg

E: Imported Sheet 1.svg into Slingshot and located the result onto the stock

F: Tried to build the outline and fill toolpaths
It appeared several of the components consist of open vectors.
Picture: 4 Toolpaths in GoliathCNC.jpg

This is unexpected and undesirable.
I have tried numerous times and with several modifications but every time there are several unwanted open vectors. Can you please have a look and point me in the right direction

Finally I have added a picture of the file Sheet 1.svg and the components filled in inkscape. I suppose not closed vectors cannot be filled

Hello Jacob,
Did you try to convert your design in svg directly on Inkscape and to import it on Slingshot?

Hi Lucia, Yes I did, and did it again just now.
There are a few small differences.
The scale is already correct and after the break apart the parts do not color black because the fill is not set. If I select it it is colored black.
Also the scale in the document properties is already 1
I had again the same result
I will send you the original Sheet 1.svg and the Sheet 1 export from Inkscape.svg I just created.
Edit: Mail bounced. Reply not possible?

1 Like

Hello Jacob
Please send it to

Thank you in advance

Any news regarding this? I ran into the same issue

1 Like

Hi Jonassella, I have understood this will be solved in the next release of Slingshot


Looking forward to it

Received my Goliath last friday and installed Slingshot today. I can import the above mentioned files and they are now correct. Problem solved :+1: