Slingshot crashes when Goliath wifi connects!

Good evening,

Im operating Slingshot, Goliath 1.2.6, Towers 1.0.14

When I work my way through Panel detect, as soon as i connect to Goliaths wifi, Slingshot crashes completely. I have completely uninstalled and reinstalled Slingshot, I have restarted my computer and Goliath and Towers. I have been working on this for about 5 hours! I have reset the Goliaths wifi. Nothing is working. Please help

Hi Reddot1,
we are sorry for the problem you are experiencing.

We discovered a bug that causes Slingshot to close when it attempts to open a popup informing that Goliath needs to be restarted.
We have realease a hotfix a few minutes ago, can you please update and check if it works now.
Lastly it would be extremely usefull if you could share the log file with us.
You can do it by filling the form on our support page.
The LOG file can be found in this folder C:\Springa\Slingshot\Log
So that we can check if your problem is the same that other users have experiences.

We will be wainting for your reply

Good afternoon Davide,
I got your reply. I downloaded the hotfix and ran into a host of other issues. Now Slingshot says Goliath is working and its not. Just prior to this Slingshot had a popup tell me the towers are operating on an old firmware version. Everything is up to date. I sent all my logs from today via the form on your support page with a wetlink. Please let me know if i can provide any further information for you.

So is this like a “one response a day” type of forum? Please tel me there is another way to get something actually accomplished. I’m seeing a lot of people wanting to sell their Goliaths for this exact reason. I have had Goliath for a YEAR. I get up the nerve to sit down and attempt to get it going. Each time I spend entire days installing, deleting, reinstalling, wifi won’t connect, tabs won’t set. It is a constant! How many people actually work here? Can I have a point of contact? Please? This is absolutely absurd!!! When you have a great product, you see loads of user videos and photos of their projects. You know what I don’t see, videos of peoples projects that actually bought one. I only see Goliath product videos. Can you tell I am frustrated beyond the point I should be?

Hi Reddot1,
we have analyzed the log file you sent us.
We can confirm that you have experienced a few times communication problems between Goliath and Slingshot. This has caused the erroneous opening of the pop-up telling to restart Goliath. But in these cases, we notice that you were able to continue the Panel Detection or the cut.
In one case, it appeared correctly:
you made a cut, which was finished, and then you went to the settings page and changed the unit of measurement. That caused the restart of Slingshot and the loss of the information about the Panel Detection that was performed. When you restarted Slingshot, it connected again to Goliath, which had already performed a Panel Detection. So, the software lost the information on the panel detection, but the robot had the information on the panel detection. For that reason, the Restart Goliath pop-up appeared.

We have to fix the bug of the Restart Goliath popup appearing wrongly, and we can also make an improvement that will allow Slingshot to copy the Panel Detection info from Goliath if the user requests it.

At least with the hotfix Slingshot doesn’t crash anymore, and if the pop appears erroneously you should be able to work anyway.

Regarding your last message, I can say that as you may have learned we are a small company and the customer service has to be improved with more people dedicated.
We are doing the best we can with the resources available at the moment. We apologize for any being as responsive as you expected.
Regarding the successful projects that were made with Goliath, the forum today is not actually the best place to search, because most of our customers share their projects through Instagram posts and stories.
We invite you to have a look at our instagram profile.

We can talk about the Wi-Fi Issue the other post you have already created.

Good morning Davide

Last night I gave up around 9pm. Goliaths WiFi is no longer detectable. In one screen it gives 3 WiFi options (none work). When I restart everything (turn Goliath off, exit slingshot and restart) it gives two WiFi options, neither of them are viable either as it is not broadcasting when I search for Goliath in my WiFi. I tried for hours. I’m at a loss at this point. Maybe a FaceTime call is in order to see if this is all user error or I’m experiencing something no one else is. The only project I have been able to cut was the demo project listed in slingshot. As soon as it finished cutting I had another error telling me to lift Goliath because it was under the towers. It was not.

Hi Reddot1,
your last message is not pertinent here can you please repost it on this topic?

Thanks in advance

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.