Slingshot not seeing Goliath

Connected Goliath to my PC, but Slingshot doesn’t see Goliath and the lights keep blinking. Uninstalled and reinstalled Slingshot, restarted PC, power cycled Goliath, and long pressed the big yellow button on top of Goliath. None of the above worked.

Any other things I can try to get Slingshot to see Goliath?Downloaded Slingshot today so I’m using the most current version. Slingshot also won’t show imported Zip files.

Hallo hsst WiFi Verbunden?

Haven’t been able to get slingshot to see Goliath still - It does connect to my PC’s WiFi, but that’s it. Tried connecting a different computer to Goliath’s WiFi with no luck - Windows says “can’t connect to this network”.

Anyone know how to reset Goliath’s WiFi? I’ve asked Springa support this several times and they won’t share. If I can connect a different computer it could show if the issue is my hardware or Springa’s. This is day three of trouble shooting

Hello, please try to update your firmware and let we know if the problem persist.

After getting the firmware update software installed - I already have the most recent Firmware 1.0.12. My version of Slingshot was downloaded Saturday and is the most current.

For anyone looking to update your Firmware here’s the steps that Springa left out:

You need .NET Core 3.1 Desktop Runtime (v3.1.17) - Windows x64 (their prompt doesn’t specify the desktop version, I got it on the 4th try)

You might need to update your com port drivers. The link in the firmware update just closed the firmware with out taking me to the proper site Drivers - FTDI and then download **Windows Driver Installer (VCP & D2XX) (I guessed and was right)

This is day 4 of trying to get past the first step to get Goliath running. My shop is on the opposite side of town from where I live. I’ve sunk 6 hours into this so far with out making a single cut.

1 Like

Just tried adding new files to to Slingshot that came from Springa support to fix my issue, and I still cannot connect Goliath to Slingshot.

I keep asking the same question with no response - Can Goliath’s WIFI be reset so I can try to connect a different PC?

Day 5 of trouble shooting and I still cannot use Goliath.

Finally got Goliath working! Springa gave me another way to connect Goliath. If you happen on this thread and have the same issue connecting directly:

Open slingshot, open a project, go to panel detection, and proceed until you get to “select connection mode” step. Select “set up a new configuration to an existing network”. This connected Slingshot and Goliath.

I wish I had this info on day 1. Since Slingshot did not see Goliath with the direct connection I didn’t bother with the project and panel detection stuff. This info needs to be under the “get started” portion of this site, and included in the manual. I’ve wasted hours of time trouble shooting.


I also had this issue, however this fix didn’t solve my problem. I ended up figuring out how to reset the WiFi for Goliath. I held the button on top of Goliath until the WiFi light turned red. I then turned Goliath off, back on, and then Slingshot was able to see Goliath.

1 Like

Thank you for your feedback, next week will be released a new version of Slingshot which will solve connection problems.

Hi, I have a similar issue with Slingshot.

I’m running it on a Mac with Parallels Desktop. Along the panel detection process, I tried both of the options to connect Goliath to the computer (self-hosted or existing) and the wifi network list stays empty everytime.
When I’m back on macos I can see a “Goliath_a315cd” network but can’t connect to it cause it asks for a password.

Springa, how can I arrange this ?

The password is in the book that came with Goliath. You have to connect it to your WiFi in the MacOS first.

Thanks Ravensix. I tried that and macOS did connect to Goliath but still no luck in Parallels in the panel detection process to see Goliath. I spend a whole day trying everything I could think of and ended up installing Windows with Bootcamp. It’s not as convenient but seems to work. I didn’t have time to go through the whole process but it should be fine

I had a similar problem. That Goliath couldn’t see my WiFi or otherwise. If i opened my mobile and made a mobile hotspot beside they suddenly connect. Without interaction. I have to do this every time.


I had luck on and off. Could complete few simple projects and had come across some problems- Goliath wifi makes a connection to towers but my bt wifi is disabled and the spindle protection error will not allow me go any further.
I have updated the slingshot as suggested today and when I checked the settings realised I had to update goliath firmware (don’t know the version) which I have done thanks to Soper.
I could make another cut and when I wanted to repeat the same cut I had problems to connect to goliath wifi gone through panel detection several times if goliath wifi gets connected my internet fails due to limited service, after several attempts managed to make the cut.
There is definitely a wifi connection problem i had an allert that goliath wifi is insecure as it uses weak data encryption???
So till today it is trial and error. I should try phone hotspot as goliath disables my BT wifi.

This weekend spent with frustration—

Sunday, 21 November

it is very un predictable and does not connect to wifi initially to goliath and then can not proceed as it is not connected to internet and sensor 2 is not connecting. after all resets spindle cage error-- very frustrating. my internet is not connected as it is connected to goliath and i could not send this message. i will try and reset my internet may be you will get this message. i tried mobile wifi but my computer wifi is being suppressed and goliath wifi has limited connectivity hence does not [ work trouble shooting does not work. i am turning off goliath to send this message.

Hello there, I have told the technical team about the problem you are experiencing, and they have told me that even if Goliath is turned off and then on again, it still remembers the last connection type used. So we kindly ask you to turno on Goliath and press and hold the yellow status button on the Goliath for 5 seconds until the LEDs turn red, this will restart the connection options and you can switch to direct Wi-Fi during panel detection.

1 Like

Thanks @Soper for sharing your experience. I had the very same problem and you made me save a lot of time. :yo-yo:

1 Like

I’m having a lot of trouble getting slingshot to see Goliath. I’m on a Mac running VirtualBox as recommended. The Mac sees Goliath wifi but slingshot does not. Pressing and holding the button on Goliath does not make the LED turn red.

I’ve tried everything I can think of and everything in this post but I’ve got nowhere.

Help please.

1 Like

I have downloaded new version ( of slingshot on my pc today seems to work fine on goliath wifi. I had problems in the past but need to repeat panel detection few times.
The latest version reset my bit selection to default 6mm and 6.35 and had to reinstall 3mm bit to make the cut.
good luck.

I’m on too. I still can’t get it to work.

Windows 10 on VirtualBox is horrible. I can’t wait for Mac version of Slingshot.

I managed to get Slingshot to connect by using a wifi dongle.

I’m now in the Firmware nightmare. Half the details seem to be missing in their instructions. Thank goodness for the forum.